COMMLOST | Connection refused | apcupsd issue

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

COMMLOST | Connection refused | apcupsd issue

Ben17
This post has NOT been accepted by the mailing list yet.
I need a help with the apcupsd. I have installed it on Ubuntu desktop to monitor the smart-UPS. I am providing  you with the configuration file along with th commands I used to try to figure this out. I’ve been doing this for over a week and couldn’t find a solutions.  I even enabled the firewall (ufw) and updated the rules so I allow any traffic to the ports 3052 & 3551. when doing the nmap, it shows that the port is closed and there is no firewall I know is in place between my Ubuntu desktop and the UPS. The service is up and running and the network and iptables are on. Did I miss something that could cause that issue. Please let me know if you could help and be patient with me as I am new to this apcpusd software. Thanks for your time and attention.


# # apcupsd.conf v1.1 ##
UPSNAME  APCUPS
UPSCABLE ether
UPSTYPE pcnet
DEVICE UPSipaddr:apc:15characterspassphrase including (upper case, lower case, !@# and numbers).
SCRIPTDIR /etc/apcupsd
PWRFAILDIR /etc/apcupsd
NOLOGINDIR /etc
NETSERVER on
NISIP 0.0.0.0
NISPORT 3551


when I did the apcaccess status I get this

~$ apcaccess status
APC      : 001,018,0447
DATE     : 2017-06-05 10:37:40 +0300
HOSTNAME : ubuntu
VERSION  : 3.14.12 (29 March 2014) debian
UPSNAME  : APCUPS
CABLE    : Ethernet Link
DRIVER   : PCNET UPS Driver
UPSMODE  : Stand Alone
STARTTIME: 2017-06-05 10:21:04 +0300
STATUS   : COMMLOST
MBATTCHG : 5 Percent
MINTIMEL : 3 Minutes
MAXTIME  : 0 Seconds
NUMXFERS : 0
TONBATT  : 0 Seconds
CUMONBATT: 0 Seconds
XOFFBATT : N/A
STATFLAG : 0x05000100
END APC  : 2017-06-05 13:30:31 +0300


however when I specify the port number when doing apcaccess I get this

~$ apcaccess status 10.10.X.X:3551
Error contacting apcupsd @ 10.10.X.X:3551: Connection refused


 When I did nmap for ports 3551 & 3052 I get the following

~$ nmap 10.10.X.X -p 3551

Starting Nmap 7.01 ( https://nmap.org ) at 2017-06-05 13:33 AST
Nmap scan report for 10.10.X.X
Host is up (0.0033s latency).
PORT     STATE  SERVICE
3551/tcp closed apcupsd

Nmap done: 1 IP address (1 host up) scanned in 0.04 seconds

~$ nmap 10.10.X.X -p 3052

Starting Nmap 7.01 ( https://nmap.org ) at 2017-06-05 13:32 AST
Nmap scan report for 10.10.X.X
Host is up (0.0032s latency).
PORT     STATE  SERVICE
3052/tcp closed powerchute

Nmap done: 1 IP address (1 host up) scanned in 0.03 seconds