Missing information in apcaccess output

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Missing information in apcaccess output

akrotov
Well ,i compiled apcupsd ver. 3.14.14 and set

UPSCABLE usb
UPSTYPE modbus


But when i'm trying to launch apcuspd i'm getting error :


Checking configuration ...
: Warning: old configuration file found.

: Expected: "## apcupsd.conf v1.1 ##"
: Found:    "UPSNAME ups1
"

: Please check new file format and
: modify accordingly the first line
: of config file.

: Processing config file anyway.
sharenet.type = Network & ShareUPS Disabled
cable.type = USB Cable
mode.type = MODBUS UPS Driver
Setting up the port ...
apctest FATAL ERROR in apctest.c at line 321
Unable to open UPS device.
  If apcupsd or apctest is already running,
  please stop it and run this program again.
apctest error termination completed

But there is no other apcupsd instances running...


On 14/09/16 13:53, Ted Mittelstaedt wrote:
the SMT series does not report all values unless you use a modern
version of apcupsd and turn on Modbus support.  You may need to
do a firmware update to your SMT to enable modbus support if it
is an older SMT.

You need to run version 3.14.13 of apcupsd for modbus support over
USB.

Please let us know if you have problems compiling 3.14.13 under
Raspbian.  And also do people a favor and bitch to the maintainers
of Raspbian to get off their duffs and update apcupsd.

Ted

On 9/13/2016 7:30 AM, akrotov wrote:
Your operating system : Raspbian GNU/Linux 7
The version of apcupsd you are using : apcupsd 3.14.10 (13 September
2011) debian
The model and UPS cable you are using :APC SMT1000RMI2U,cable = USB

A clear description of the problem:

Hello guys !

I have a problem,my configuration working correctly but in Web interface
( as well as in apcaccess) i cant find values LOADPCT,LINEV and ITEMP
.For example output apcaccess

APC      : 001,028,0738
DATE     : 2016-09-13 14:10:38 +0000
HOSTNAME : p-ups05
VERSION  : 3.14.10 (13 September 2011) debian
UPSNAME  : ups1
CABLE    : USB Cable
DRIVER   : USB UPS Driver
UPSMODE  : Stand Alone
STARTTIME: 2016-08-23 09:27:07 +0000
MODEL    : Smart-UPS 1000
STATUS   : ONLINE
BCHARGE  : 100.0 Percent
TIMELEFT :  93.0 Minutes
MBATTCHG : 5 Percent
MINTIMEL : 3 Minutes
MAXTIME  : 0 Seconds
ALARMDEL : 30 seconds
BATTV    : 27.0 Volts
NUMXFERS : 2
XONBATT  : 2016-09-09 12:56:21 +0000
TONBATT  : 0 seconds
CUMONBATT: 16 seconds
XOFFBATT : 2016-09-09 12:56:29 +0000
STATFLAG : 0x07000008 Status Flag
MANDATE  : 2013-08-09
SERIALNO : AS1332235581
NOMBATTV :  24.0 Volts
FIRMWARE : UPS 08.8 / ID=18
END APC  : 2016-09-13 14:11:12 +0000

How can i solve this problem?

------------------------------------------------------------------------------
_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users


------------------------------------------------------------------------------
_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users
------------------------------------------------------------------------------
Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today.http://sdm.link/intel
_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users