PCNET Issue

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

PCNET Issue

Kyle Johanson

I am having an issue getting an SMT1500 UPS with a AP9630 network management card to work correctly.  I am not a Linux expert by any means but did manage to download the tarball, complied it and added the configure option of –enable-pcnet successfully.

 

Ubuntu 14.04

APCUPSD Version – 3.14.14

 

What happens is when I run apctest is errors out and I am not sure exactly why.  I did set the username from the selection of apc or device to apc in the shutdown menu and set a password longer than 15 characters

 

I can ping the UPS from the Ubuntu machine successfully. 

 

The firmware on the APC AP9630 has been updated to the latest version.

 

2017-02-10 15:58:45 apctest 3.14.14 (31 May 2016) debian

Checking configuration ...

sharenet.type = Network & ShareUPS Disabled

cable.type = Ethernet Link

mode.type = PCNET UPS Driver

Setting up the port ...

apctest FATAL ERROR in pcnet.c at line 669

Cannot bind socket (98)

--------------------------------------------------------------------------

 

## apcupsd.conf v1.1 ##

UPSCABLE ether

UPSTYPE pcnet

DEVICE 192.168.50.5:apc:Nelsonsportsups1

LOCKFILE /var/lock

SCRIPTDIR /etc/apcupsd

PWRFAILDIR /etc/apcupsd

NOLOGINDIR /etc

ONBATTERYDELAY 6

BATTERYLEVEL 5

MINUTES 3

TIMEOUT 0

ANNOY 300

ANNOYDELAY 60

NOLOGON disable

KILLDELAY 0

NETSERVER on

NISIP 127.0.0.1

NISPORT 3551

EVENTSFILE /var/log/apcupsd.events

EVENTSFILEMAX 10

UPSCLASS standalone

UPSMODE disable

STATTIME 0

STATFILE /var/log/apcupsd.status

LOGSTATS on

DATATIME 0

 

Any thoughts on what I might try to do to fix this? 

 

 

 


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PCNET Issue

Kyle Johanson

I also wanted to add that I looked for an answer to my issue and found someone with a very similar issue but it wasn’t clear as to how it was solved.  The person stated that they added a powerchute client and his issue was solved without any detail. I looked at the powerchute web interface setup of the PC9630 card I have with an SMT-1500 but my confusion is what IP do you use the UPS or the server that is trying to be shut down?  In addition I have two outlet groups how do I control each group individually, I am guessing each client should be the server IP that I am trying to shut down??

 

 

From: Kyle Johanson [mailto:[hidden email]]
Sent: Friday, February 10, 2017 4:11 PM
To: [hidden email]
Subject: [Apcupsd-users] PCNET Issue

 

I am having an issue getting an SMT1500 UPS with a AP9630 network management card to work correctly.  I am not a Linux expert by any means but did manage to download the tarball, complied it and added the configure option of –enable-pcnet successfully.

 

Ubuntu 14.04

APCUPSD Version – 3.14.14

 

What happens is when I run apctest is errors out and I am not sure exactly why.  I did set the username from the selection of apc or device to apc in the shutdown menu and set a password longer than 15 characters

 

I can ping the UPS from the Ubuntu machine successfully. 

 

The firmware on the APC AP9630 has been updated to the latest version.

 

2017-02-10 15:58:45 apctest 3.14.14 (31 May 2016) debian

Checking configuration ...

sharenet.type = Network & ShareUPS Disabled

cable.type = Ethernet Link

mode.type = PCNET UPS Driver

Setting up the port ...

apctest FATAL ERROR in pcnet.c at line 669

Cannot bind socket (98)

--------------------------------------------------------------------------

 

## apcupsd.conf v1.1 ##

UPSCABLE ether

UPSTYPE pcnet

DEVICE 192.168.50.5:apc:Nelsonsportsups1

LOCKFILE /var/lock

SCRIPTDIR /etc/apcupsd

PWRFAILDIR /etc/apcupsd

NOLOGINDIR /etc

ONBATTERYDELAY 6

BATTERYLEVEL 5

MINUTES 3

TIMEOUT 0

ANNOY 300

ANNOYDELAY 60

NOLOGON disable

KILLDELAY 0

NETSERVER on

NISIP 127.0.0.1

NISPORT 3551

EVENTSFILE /var/log/apcupsd.events

EVENTSFILEMAX 10

UPSCLASS standalone

UPSMODE disable

STATTIME 0

STATFILE /var/log/apcupsd.status

LOGSTATS on

DATATIME 0

 

Any thoughts on what I might try to do to fix this? 

 

 

 


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PCNET Issue

William P.N. Smith
In reply to this post by Kyle Johanson
Generally you can’t run apctest while apcupsd is running, stop the daemon, run apctest, and then restart the daemon.

You should be able to run apcaccess in order to get current stats while the daemon is running…

On Feb 10, 2017, at 6:11 PM, Kyle Johanson <[hidden email]> wrote:

I am having an issue getting an SMT1500 UPS with a AP9630 network management card to work correctly.  I am not a Linux expert by any means but did manage to download the tarball, complied it and added the configure option of –enable-pcnet successfully.
 
Ubuntu 14.04
APCUPSD Version – 3.14.14
 
What happens is when I run apctest is errors out and I am not sure exactly why.  I did set the username from the selection of apc or device to apc in the shutdown menu and set a password longer than 15 characters
 
I can ping the UPS from the Ubuntu machine successfully.  
 
The firmware on the APC AP9630 has been updated to the latest version.
 
2017-02-10 15:58:45 apctest 3.14.14 (31 May 2016) debian
Checking configuration ...
sharenet.type = Network & ShareUPS Disabled
cable.type = Ethernet Link
mode.type = PCNET UPS Driver
Setting up the port ...
apctest FATAL ERROR in pcnet.c at line 669
Cannot bind socket (98)
--------------------------------------------------------------------------
 
## apcupsd.conf v1.1 ##
UPSCABLE ether
UPSTYPE pcnet
DEVICE 192.168.50.5:apc:Nelsonsportsups1
LOCKFILE /var/lock
SCRIPTDIR /etc/apcupsd
PWRFAILDIR /etc/apcupsd
NOLOGINDIR /etc
ONBATTERYDELAY 6
BATTERYLEVEL 5
MINUTES 3
TIMEOUT 0
ANNOY 300
ANNOYDELAY 60
NOLOGON disable
KILLDELAY 0
NETSERVER on
NISIP 127.0.0.1
NISPORT 3551
EVENTSFILE /var/log/apcupsd.events
EVENTSFILEMAX 10
UPSCLASS standalone
UPSMODE disable
STATTIME 0
STATFILE /var/log/apcupsd.status
LOGSTATS on
DATATIME 0
 
Any thoughts on what I might try to do to fix this?  
 
 
 
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users
Loading...