Ubuntu 16.04LTS make install failure

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Ubuntu 16.04LTS make install failure

John Connell
Am having problems running "make install’ with version 3.14.14 with insserv and update-rc.d failures.

I configured as :-

:~/apcupsd-3.14.14$ ./configure --enable-usb --enable-modbus-usb -
-prefix=/usr/local

Then ran make —n  install  with no apparent problems but running without the -n option gave:-

:~/apcupsd-3.14.14$ sudo make install
src
src/lib
src/drivers
src/drivers/apcsmart
src/drivers/dumb
src/drivers/net
src/drivers/pcnet
src/drivers/usb
src/drivers/usb/linux
src/drivers/snmplite
src/drivers/modbus
src/libusbhid
COPY apcupsd => /sbin/apcupsd
COPY apctest => /sbin/apctest
COPY apcaccess => /sbin/apcaccess
COPY smtp => /sbin/smtp
platforms
platforms/etc
MKDIR /etc/apcupsd
COPY apcupsd.conf => /etc/apcupsd/apcupsd.conf
COPY changeme => /etc/apcupsd/changeme
COPY commfailure => /etc/apcupsd/commfailure
COPY commok => /etc/apcupsd/commok
COPY offbattery => /etc/apcupsd/offbattery
COPY onbattery => /etc/apcupsd/onbattery
platforms/debian
------------------------------------------------------------
debian distribution installation
------------------------------------------------------------
COPY apcupsd => /etc/init.d/apcupsd
insserv: warning: script 'apcupsd' missing LSB tags and overrides
insserv: There is a loop between service logitechmediaserver and apcupsd if stoppe
d
insserv: loop involving service apcupsd at depth 2
insserv: loop involving service logitechmediaserver at depth 1
insserv: Stopping apcupsd depends on logitechmediaserver and therefore on system f
acility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
Makefile:10: recipe for target 'install-debian' failed
make[3]: *** [install-debian] Error 1
../../autoconf/targets.mak:68: recipe for target 'install' failed
make[2]: *** [install] Error 2
../autoconf/targets.mak:110: recipe for target 'debian_DIR' failed
make[1]: *** [debian_DIR] Error 2
autoconf/targets.mak:110: recipe for target 'platforms_DIR' failed
make: *** [platforms_DIR] Error 2

I previously had version 3.14.13 running with logitechmediaserver on Ubuntu 14.04 LTS Server without problems. This issue is on a clean install of 16.04LTS Server.

As a new subscriber to this list, apologies if my first attempt at sending this is duplicated but I got no confirmation that it had uploaded successfully.

John Connell



------------------------------------------------------------------------------

_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users
Loading...