apcupsd / apctest segmentation fault

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

apcupsd / apctest segmentation fault

olfried joergensen
Hello there,
with Ubuntu 16.04 (Xenial Xerus), running on a Fujitsu 3400B, Celeron
G3900. While configuring an APC BACK-UPS 650 I get - with the following
configuration


## apcupsd.conf v1.1 ##
UPSNAME ESAUPS
UPSCABLE usb
USBTYPE usb
DEVICE
POLLTIME 60
LOCKFILE /var/lock
UPSCLASS standalone

this error:

2016-07-10 15:24:54 apctest 3.14.12 (29 March 2014) debian
Checking configuration ...
Terminating due to configuration file errors.
Segmentation fault (core dumped)

I tested a smaller an a larger configuration according to the manual
resulting in the same message

On my retired server running Ubuntu 12.04 LTS acpupsd worked aout of the
box (I tested the "old"configuration on the new machine without fortune.)

lsusb shows:

Bus 001 Device 003: ID 051d:0002 American Power Conversion
Uninterruptible Power Supply

dmesg gives this:

[ 7481.567912] apctest[2673]: segfault at 0 ip 000000000040921b sp
00007ffe44057c20 error 4 in apctest[400000+47000]

I also tried to compile 3.14.14 but without fortune, funny error
messages I've never seen before. (the "actual" debian package is
apcupsd 3.14.12 (29 March 2014)).

Could someone lead me to a correct configuration or has someone had the
same error and a solution?

I asked this question on the ask-ubuntu list, but didn't got an answer,
hope you can help, as a server without ups is like driving a bike
without air in the tires.

Thanks in advance
Olfried

------------------------------------------------------------------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity planning
reports.http://sdm.link/zohodev2dev
_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users