./configure fault

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

./configure fault

Oswalt, Ed (GE Healthcare)

Trying to configure apc (apcupsd-3.14.14.tar.gz) download from http://www.apcupsd.org/#.

 

./configure fails to determine the operating system type:  SuSE Version 11.

 

SuSE is stated to be fully supported; no specific configuration needs.

 

The compressed tarball is purported to be ‘source’. Following the ‘Installation from Source’ directions…

 

cd apcupsd-3.14.14

 

 

./configure

 

 

  1. I know the compiler exists; I used it to install a different package yesterday.

 

Any suggestions?

 

Ed Oswalt

Sr. Advance Manufacturing Test Equipment Engineer

GE Healthcare

[hidden email]

262-312-7077

 


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ./configure fault

Timothe Litt

Any suggestions?

Don't worry about the "linux unknown".

You are expecting to use gnu compilers, gcc.

apcupsd is looking for C++

"which g++" would be a better test than "which gcc".

configure reported that it's not  installed.  It's probably right (or not on your PATH).

c++ may be separate package for SuSE - I'm not a user.

Timothe Litt
ACM Distinguished Engineer
--------------------------
This communication may not represent the ACM or my employer's views,
if any, on the matters discussed. 
On 29-Jun-17 15:04, Oswalt, Ed (GE Healthcare) wrote:

Trying to configure apc (apcupsd-3.14.14.tar.gz) download from http://www.apcupsd.org/#.

 

./configure fails to determine the operating system type:  SuSE Version 11.

 

SuSE is stated to be fully supported; no specific configuration needs.

 

The compressed tarball is purported to be ‘source’. Following the ‘Installation from Source’ directions…

 

cd apcupsd-3.14.14

 

 

./configure

 

 

  1. I know the compiler exists; I used it to install a different package yesterday.

 

Any suggestions?

 

Ed Oswalt

Sr. Advance Manufacturing Test Equipment Engineer

GE Healthcare

[hidden email]

262-312-7077

 




------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users

smime.p7s (6K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ./configure fault

Manfred Schwarb
In reply to this post by Oswalt, Ed (GE Healthcare)
Am 29.06.2017 um 21:04 schrieb Oswalt, Ed (GE Healthcare):
> Trying to configure apc (apcupsd-3.14.14.tar.gz) download from http://www.apcupsd.org/#.
>
> ./configure fails to determine the operating system type:  SuSE Version 11.
>

You will find prepared binaries for SLE 11 at
https://software.opensuse.org/package/apcupsd

You are just one click away from your happiness.

Cheers,
Manfred


> SuSE is stated to be fully supported; no specific configuration needs.
>
> The compressed tarball is purported to be 'source'. Following the 'Installation from Source' directions...
>
> cd apcupsd-3.14.14
>
> [cid:image006.jpg@01D2F0E0.A240C520]
>
> ./configure
>
> [cid:image007.jpg@01D2F0E0.A240C520]
>
>
>   1.  I know the compiler exists; I used it to install a different package yesterday.
> [cid:image009.jpg@01D2F0E0.A240C520]
>
>
>
> Any suggestions?
>
>
> Ed Oswalt
> Sr. Advance Manufacturing Test Equipment Engineer
> GE Healthcare
> [hidden email]<mailto:[hidden email]>
> 262-312-7077
>
>
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>
>
>
> _______________________________________________
> Apcupsd-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/apcupsd-users
>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ./configure fault

Ted Mittelstaedt-5
In reply to this post by Oswalt, Ed (GE Healthcare)
Ed, have you compiled other packages successfully?  Something isn't
setup right in your development environment.

Ted

On 6/29/2017 12:04 PM, Oswalt, Ed (GE Healthcare) wrote:

> Trying to configure apc (apcupsd-3.14.14.tar.gz) download from
> http://www.apcupsd.org/#.
>
> ./configure fails to determine the operating system type:  SuSE Version 11.
>
> SuSE is stated to be fully supported; no specific configuration needs.
>
> The compressed tarball is purported to be ‘source’. Following the
> ‘Installation from Source’ directions…
>
> cd apcupsd-3.14.14
>
> ./configure
>
>  1. I know the compiler exists; I used it to install a different package
>     yesterday.
>
> Any suggestions?
>
> Ed Oswalt
>
> Sr. Advance Manufacturing Test Equipment Engineer
>
> GE Healthcare
>
> [hidden email] <mailto:[hidden email]>
>
> 262-312-7077
>
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>
>
>
> _______________________________________________
> Apcupsd-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/apcupsd-users
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Apcupsd-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/apcupsd-users
Loading...